Slow Performance Issues

System
System Administrator admin
This discussion was created from comments split from: Slow Performance.

Comments

  • I also have noticed pretty poor performance on the web app, particularly on my older laptop. One issue that's very noticeable recently is that when I click the up icon on the right of a transaction to close it, the spot where the transaction was stays white until I scroll around the screen for a couple of seconds. More generally a lot of the user actions that I take feel very unresponsive. Changing tabs to the transactions list often freezes animations slightly and takes around a second for anything to happen. Also when I scroll through the transactions the new transactions only show up if I stop scrolling or scroll very slowly.

    This doesn't actually impact the usability most of the time, but it is very annoying. The only time where it's actually been a problem is when I've clicked on two things in quick succession, and the second click doesn't register or does something unexpected because the screen changed slowly after the first click.
  • Coach Natalie
    Coach Natalie Administrator, Moderator admin
    Hello @georgewitteman,

    Thank you for taking the time to post to the Community regarding program performance, although I apologize that you're experiencing these issues with Simplifi. 

    To clarify, is this also occurring for you after importing years' worth of transactions? If so, I'd definitely follow along with this post, as we are working on improving the performance of the program after historical data imports have taken place. :smile:

    -Coach Natalie
  • I only had 3 months of data imported when I signed up, but that was almost a year ago
  • Coach Natalie
    Coach Natalie Administrator, Moderator admin
    edited May 27
    Hello @georgewitteman,

    Thanks for clarifying!

    It sounds like the performance issues you've experienced may be due to the age and performance-abilities of the older laptop that you mentioned. If it seems to be device-specific, I'd say that that's the most likely culprit.

    With that being said, you may consider clearing the cache & cookies on the browser that you're using on that laptop, to see if that helps to clear things up for you.

    Otherwise, I can share the information with my Team to see if they have any insight, but would need some videos, as well as the device and browser specs, to provide to them. We'd want to be able to show them what specifically is occurring for you. :smile:

    -Coach Natalie
  • It's most noticeable on my older laptop, but my work laptop is much newer and it happens there too. I can try and take a screen recording to show what I'm talking about. Is there somewhere non-public I can send it since it will have my transaction information?

    I'm also on the latest version of Chrome and macOS.

    My work laptop is a 2019 Macbook Pro and personal computer is a 2013 Macbook Pro.
  • Coach Natalie
    Coach Natalie Administrator, Moderator admin
    Hello @georgewitteman,

    Thanks for posting back!

    I have gone ahead and emailed you a link to our Secure File Exchange, so you can upload the screen recording to me there -- please let me know once done. 

    I will also need the actual version number of your OS and the browser. Thanks! :wink:

    -Coach Natalie
This discussion has been closed.