Slow Performance after importing years worth of transactions (edited)

nmcmahon1215
nmcmahon1215 Member ✭✭✭
edited May 2021 in Feedback
Hello,

A while back I imported all of my transactions from Mint into Simplifi. This function worked great, and I have a transaction history all the way back to 2015. However, I've noticed that since then, the overall performance of Simplifi has slowed down greatly. At first the main point of slowness was on the initial app load as it fetched all the transactions. Now, I'm experiencing slowness with regular actions, such as marking a transaction as reviewed.

Can performance be looked into? For example, while I like the have my full transaction history, I don't need it all at once. The app could load just the past couple months of transactions and fetch older transactions as needed in the UI

Thanks!
«134

Comments

  • Coach Natalie
    Coach Natalie Administrator, Moderator admin
    Hello @nmcmahon1215,

    Thanks for posting!

    To clarify, are you experiencing this issue on the Simplifi Mobile App, Web App, or both? If this is occurring on the Mobile App specifically, I'd suggest uninstalling and reinstalling, while performing a device reboot in between, to see if that helps to clear things up a bit. 

    Please let me know! :smile:

    -Coach Natalie
  • nmcmahon1215
    nmcmahon1215 Member ✭✭✭
    It occurs on both, but is probably more noticeable on the desktop web app.

    For example, clicking the checkmark to mark a transaction as reviewed takes several seconds. Delays in animation cause incorrect clicks and further delays.
  • Coach Natalie
    Coach Natalie Administrator, Moderator admin
    Hello @nmcmahon1215,

    Thanks for posting back and confirming!

    I'm not experiencing any latency issues personally, from either the Web or the Mobile Apps. With that being said, I'd suggest clearing your cache and cookies to see if that helps to clear things up, or possibly trying from a different browser.

    Let me know how it goes! :smile:

    -Coach Natalie
  • nmcmahon1215
    nmcmahon1215 Member ✭✭✭
    I've done that several times and it does not seem to help.

    I started noticing the issue when I imported all of my transactions from Mint. This made load times significantly slower and it's worsened over time. Can you try to reproduce with a large number of transactions? For reference, I have transactions dating back to 2015. For reference, I have almost 7000 transactions in my account
  • Coach Natalie
    Coach Natalie Administrator, Moderator admin
    edited February 2022
    Hello @nmcmahon1215,

    Thanks for trying those steps and posting back!

    I found a Bug Ticket regarding this same set of circumstances, and the same types of issues presented in Simplifi, so I have gone ahead and added your information to the Ticket. I will be sure to post back as soon as any updates become available. :smile:

    Thank you,

    Coach Natalie

    SIMPL-8242
  • nmcmahon1215
    nmcmahon1215 Member ✭✭✭
    Thank you!
  • This is also an issue for me. I'm having trouble editing and cleaning up transactions due to the latency on the web. 
  • Coach Natalie
    Coach Natalie Administrator, Moderator admin
    Hello @damufunman,

    Thank you for reporting this to the Community, although I'm sorry to hear that you're also experiencing latency issues in Simplifi.

    To clarify, is this also occurring for you after importing year's worth of transactions? If so, I would definitely suggest following along with this post for any updates on the exsiting Bug Ticket! :smile:

    -Coach Natalie
  • I have the same problem after importing years of Mint transactions. Making updates, searching, etc. took a long time. Marking a transaction as "Ignore from Reports" took 15-20 seconds, each time (and you can't bulk-add that!).

    Clearing my cache from my Chrome browser settings seemed to have fixed the problem... for a while. After using the site for an hour or so, it's pretty slow again, although not as horrendously slow as before.
  • Coach Natalie
    Coach Natalie Administrator, Moderator admin
    Hello @notsosimpli,

    Thank you for reporting this, although I'm sorry to hear that you're also experiencing this latency issue.

    This issue is still being worked on by our Product Team, so please be sure to follow along here for updates! :blush:

    -Coach Natalie
  • josh_shannon
    josh_shannon Member ✭✭✭
    I know this is a slightly old thread, but I'm seeing the same issues as @notsosimpli. I imported my Mint transaction history from July 2008, so I have 13 years worth of transaction history imported into Simplifi. I have been using Simplifi since Dec 2020 and I really like it, but the web and android interface is extremely slow. Clearing web application cache in Chrome definitely helps, but it also gets much worse over time. Before I cleared the cache I saw it had over 355 MB of cache storage. After clearing cache and using it for maybe 5 minutes, I'm seeing 65 MB of cache storage. I'm not sure if that's related to the poor performance over time, but it does seem like a lot of cache for a web application. My android app, running on my Pixel 4a, has similar performance issues. Opening the menu, clicking on links, searching/opening/editing transactions, opening a report screen, all takes at least 3-5 seconds. I still love this service and will continue using it because of all the other benefits. However, fixing these performance issues would be the difference between a good, useful app and a phenomenal one that I'd recommend to everyone.
  • nmcmahon1215
    nmcmahon1215 Member ✭✭✭
    FWIW, I’m still seeing really poor performance on the web app. Simple things like marking a transaction as reviewed or changing a category take several seconds each. At times it’s basically unusable. 
  • Coach Natalie
    Coach Natalie Administrator, Moderator admin
    edited November 2021
    Hello @josh_shannon,

    Thanks for providing your feedback on this issue, although I'm sorry to hear that you're also experiencing latency and delays after importing data from Mint.

    I did go ahead and add your information to the ticket and will be sure to post back as soon as an update is received. I also provided my Team with this Community post in hopes that the descriptions provided here of the various issues will help shine some light on the situation. 

    @nmcmahon1215, it does look like these issues are still being worked on, although I don't have an ETA on a resolution as of yet. Please be sure to stay tuned here for future updates!

    -Coach Natalie
  • For those of you that feel the slowness and latency my be due to the chrome cache, I suggest running Simplifi in a chrome incognito browser (you can open one from the top right crhome menu), as the incognito browser does not cache. 
  • Matt C
    Matt C Member
    Piling on here!
    • I have ~10 years of transactions back to 2012
    • Very tedious and slow to  tagging, recategorizing, updating payee
    • never less than 10 seconds per action ... click tag .... wait 10 seconds ... get toast notification 
    • Clearing the cache works for about 4 or 5 actions, then back to latency
  • Coach Natalie
    Coach Natalie Administrator, Moderator admin
    Hello @Matt C,

    Thank you for reporting this, although I'm sorry to hear that you're also seeing this issue in Simplifi.

    Although there's still no update to provide on the Ticket for this issue, I did go ahead and get your information added, as well as a description of what you're experiencing. 

    Please be sure to stay tuned for future updates! :smile:

    -Coach Natalie
  • nmcmahon1215
    nmcmahon1215 Member ✭✭✭
    Hi @Coach Natalie,

    Do you have any updates on this? Been a year and a half since I originally reported the issue and there is still some very noticeable latency for performing any action. Marking a transation as review takes a few seconds per transaction.
  • Coach Natalie
    Coach Natalie Administrator, Moderator admin
    Hello @nmcmahon1215,

    Thanks for reaching out!

    Sadly, there hasn't been an update on this one as of yet. I know that the Team is aware of the latency issues and that it's being worked on, however, it doesn't look like they've identified the best approach on how to tackle it quite yet.

    I apologize for the delay and will be sure to keep you posted as soon as we receive any news. Thank you for your continued patience! 

    -Coach Natalie
  • SamM
    SamM Member ✭✭
    I am having the same issue. I have transactions dating back to 2012. Anything I do in Simplifi is so slow that it's practically unusable. I have this problem on multiple browsers, on the iphone app, and on the desktop app. If this is not fixed soon I'm going to be looking for an alternative to Simplifi, because it's just too difficult to use when it's this slow.
  • Flopbot
    Flopbot Superuser ✭✭✭✭✭
    edited November 2022
    @SamM,

    I just want to confirm that you are indeed talking about Simplifi by Quicken, correct?  Quicken desktop - the traditional Quicken offering - has been around for decades.  It too has a mobile app and my last experience with it was that it was completely unusable due to slowness.  Simplifi has only been around since 2019 and I haven’t noticed that level of app slowness.

    Because of your statement about “transactions dating back to 2012”, I want to make sure you didn’t find yourself in the wrong forum…happens allot.

    If you are talking about Simplifi, kudos on having the determination and fortitude to upload 6+ years worth of transactions!  :)
    Chris
    Quicken Desktop user since 2014.
    New to Simplifi in 2021.
  • Coach Natalie
    Coach Natalie Administrator, Moderator admin
    edited November 2022
    Hello @SamM,

    Thank you for reaching out to the Community regarding this issue, although I'm sorry to hear that you're also experiencing slowness with Simplifi after importing years' worth of transactions. 

    The slowness and latency issues on the Mobile App are actively being worked on in general, as many users experience this type of behavior, so hopefully you see some improvements there very soon. Otherwise, our Product Team is aware of the issue with slowness after importing years' worth of transactions on both the Mobile App and Web App. There is no ETA on a resolution as of yet, however, we'll be sure to update this post accordingly as soon as we receive any news. 

    We appreciate your patience as we work to improve Simplifi!

    -Coach Natalie
  • nmcmahon1215
    nmcmahon1215 Member ✭✭✭
    FWIW, This affects the web app too, not just the mobile app
  • SamM
    SamM Member ✭✭
    @Coach Natalie This happens on the web as well, not just on the mobile app.
  • SamM
    SamM Member ✭✭
    @Flopbot Yes, I am talking about Simplifi by Quicken.
  • MoneyBags
    MoneyBags Member
    I'm having this issue, on both the web and phone apps. It began about a month ago, though I imported transactions maybe over six months ago. In other words, the performance issue began long after the import took place.
  • Coach Natalie
    Coach Natalie Administrator, Moderator admin
    edited January 2023
    Hello @MoneyBags,

    Thanks for posting, although I'm sorry to hear that you're also seeing this issue in Simplifi. 

    If you believe the latency you're experiencing on the Simplifi Web App is due to having imported 3+ years' worth of transactions, I'd definitely suggest following along here for updates on the known issue. 

    However, if you believe that the latency could be caused by something else, I'd suggest attempting to perform the action(s) that result in latency from a different browser, as well as in incognito mode, to see if performance improves. If you see an improvement, it could be that your cache and cookies need to be cleared on your primary browser. 

    Also, I've seen multiple users recommend using Chrome with Simplifi for the best performance. :smile:

    -Coach Natalie
  • MoneyBags
    MoneyBags Member
    As I said, it occurs with both the web and phone app, so I don't think it's a browser issue. I do use Chrome. Nevertheless, I tried Safari, and had the same sluggish performance as it started up. I went to Transactions, and there were none. It slowly populated transactions, but the vertical dots in the rightmost column were missing. After about a minute, it got its act together. Even this is far less severe than the session I had when I posted. Also, it happens when I first access the web or phone app, and resolves after a while.

    So, not a browser issue, and occurs only in the first few minutes of use.
  • Coach Natalie
    Coach Natalie Administrator, Moderator admin
    edited January 2023
    Hello @MoneyBags,

    The same issue is occurring on the Mobile App after importing years' worth of transactions, as well as in general. We have a post here that can be followed for the latency issues on the Mobile App (our Team is hard at work on fixing the Mobile App). 

    Since it sounds like this is what you're experiencing, I'd suggest following both this thread and the one regarding the Mobile App for updates.

    I hope this helps!

    -Coach Natalie
  • I have this issue too and I only have 2 years worth of transactions. This is my only major issue with this software, but it is enough for me to be seriously considering canceling my subscription.